Algara 7.4 banner


Стъпки за актуализиране от SOS 7.3 към SOS версия 7.4
#1
Темата се създава с цел кратка инструкция, която описва необходимите стъпки за надграждане (актуализация) на StotinkaOS 7.3 и преминаване към StotinkaOS 7.4 Алгара

Стъпка 1.

1.1. Отваряте терминала, който сe намира в Програми > Системни инструменти > Терминал

1.2. Вписвате се като root потребител със следната команда:
Код:
su - 
парола: тук въвеждате паролата за root

Стъпка 2. Преконфигуриране на epel хранилището.

2.1. С удобен за вас редактор отваряте epel.repo файла

- Отваряне на файла с редактора nano
Код:
nano /etc/yum.repos.d/epel.repo

- Отваряне на файла а редактора gedit
Код:
gedit /etc/yum.repos.d/epel.repo

2.2 Следва да добавите реда exclude=libgpod под записа [epel], за да стане по този начин:
Цитат:[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
exclude=libgpod

Запазвате променение и затваряте редактора.

Стъпка 3. Връщане на версия за пакета libgpod

Отново като root, поставяте една след друга следните команди в терминала.
Код:
yum clean all
yum clean metadata
yum downgrade libgpod


Стъпка 4. Важи за тези от вас, които имат инсталиран WINE на системата си или имат следния докладван проблем с актуализацията на Opus.

Код:
Грешки в удовлетворяването на зависимости:

Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

 1. You have an upgrade for opus which is missing some
    dependency that another package requires. Yum is trying to
    solve this by installing an older version of opus of the
    different architecture. If you exclude the bad architecture
    yum will tell you what the root cause is (which package
    requires what). You can try redoing the upgrade with
    --exclude opus.otherarch ... this should give you an error
    message showing the root cause of the problem.

 2. You have multiple architectures of opus installed, but
    yum can only see an upgrade for one of those architectures.
    If you don't want/need both architectures anymore then you
    can remove the one with the missing update and everything
    will work.

 3. You have duplicate versions of opus installed already.
    You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Защитени multilib версии: opus-1.0.2-6.el7.i686 != opus-1.1.2-1.el7.sos.x86_64


4.1. Преди да актуализирате ще трябва да премахнете WINE. За целта отново като root изпълнете в терминала командите:
Код:
yum clean all
yum clean metadata
yum remove wine*
yum remove gstreamer1-plugins-base.i686


Внимание! Това ще премахне wine от системата. Ако ви трябва, след като актуализирате до 7.4 си го инсталирайте отново.

Стъпка 5. Е за тези от вас, които използват Flatpak от нашето хранилище, ако това е така ще трябва да го деинсталирате. За целта кaто root изпълнете следната команда.

Код:
sudo yum remove flatpak


Стъпка 6. АКТУАЛИЗИРАЙТЕ

Като root изпълнете следната команда в терминала:
Код:
yum update -y


Забележка!

- За да бъде успешна актуализацията, моля уверете се, че машината е включена към Интернет.
- По време на  актуалзициите не изключвайте компютъра.
- Актуализациите мога да продължат по-дълго, бъдете търпеливи.
- След като в терминал се изпише Успешно, моля рестартирайта система си, за да влязат в сила всики актуализации.  
Отговори




Потребители разглеждащи темата: 1 гост(и)