Инсталиране (преминаване) на Mozilla Firefox-ml последна версия
#1
Здравейте,

Както знаете стандартния браузър по подразбиране - Firefox в StotinkaOS, е Extended Support Release (ESR) версия, която върви малко по-назад от актуалните версии разработвани от корпорация Mozilla. Въпреки, че Firefox ESR е добре поддържан, обновява се редовно и грешките в него се изчистват навреме, ние от екипа решихме, че би било добре да предоставим алтернатива на нашите потребители и на тези от вас, които желаят да си инсталират по една или друга причина последна версия на браузъра.

От днес започваме да осигуряваме и  поддържаме най-новите налични версии на Firefox, които ще влизат в нашите хранилища, за да може лесно потребителите да инсталират или обновят от ESR версията към ML версия.


Важно!  

На този етап пакетите на Firefox-ml ще се намират в StotinkaOS-Plus хранилището, което е изключено по подразбиране, защото някои пакети, които се намират в него, надграждат други пакети от [ base ] хранилищата на дистрибуцията, а за нас е приоритетно важно да запазим стабилността. Активирането и употребата на StotinkaOS-Plus хранилището, трябва да става внимателно и да се спазват инструкциите, за да няма възникнали проблеми.

 * Пакети намиращи се в StotinkaOS-Plus - git, zsh, emacs , sqlite

 * Всичко налично в хранилището, може да се види - ТУК

 * Тези от вас, които използват някои от посочените, е задължително да прочетата глава А2:


А1: Инсталирате или обновяване до последна налична версия на Firefox.

 * Важно е да спазвате инструкциите точно!

 * Всички команди се изпълняват с root права!


1. Разрешавате StotinkaOS-Plus хранилището:

Код:
yum-config-manager --enable StotinkaOS-Plus

2. Актуализираме браузъра или цялата система, за да инсталираме новия ъпдейт.

2.1 Само за браузъра:

Код:
yum update firefox

2.2. Цялата система:

Код:
yum update


3. Само в случай, че сте премахнали Firefox и го нямате инсталиран:

Код:
yum install firefox


А2: Избягване надграждане на пакет от StotinkaOS-Plus да надгражда друг от base.

* За да се избегне подобно надграждане трябва да се направи допълнителна конфигурация на хранилището StotinkaOS-Plus. За целта е необходимо да се добави изключение за пакета, който ползвате и да му забраните да надгражда съществуващ такъв в base.

 * Това става като се добави един ред exclude=<име на пакет> в края на конфигурацията за хранилището StotinkaOS-Plus, която се намира в /etc/yum.repos.d/StotinkaOS.repo


Пример!   

Ако искате да забраните emacs пакета:

Код:
nano /etc/yum.repos.d/StotinkaOS.repo

и най-долу се добавя exclude=emacs , след което с Ctr+o (буквата о) запазваме промените:

Цитат:[StotinkaOS-Plus]
name=StotinkaOS-$releasever - Plus files
baseurl=http://...
        https://mirrors....
gpgcheck=1
skip_if_unavailable=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-StotinkaOS-7
exclude=emacs

Бележка: 

Ако желаете да деактивирате хранилището StotinkaOS-Plus, изпълнете следната команда:

Код:
yum-config-manager --disable StotinkaOS-Plus
Отговори
#2
Здравейте
при мен се получи грешка
изпълнил съм всичко по точка А1 и A2

Код:
# yum update firefox
Заредени плъгини: fastestmirror, langpacks, nvidia, priorities
Loading mirror speeds from cached hostfile
* StotinkaOS-Base: stotinkaos.net
* StotinkaOS-Plus: stotinkaos.net
* StotinkaOS-Wine: stotinkaos.net
* base: mirrors.neterra.net
* elrepo: ftp.ines.lug.ro
* epel: mirrors.uni-ruse.bg
* extras: mirrors.neterra.net
* updates: mirrors.neterra.net
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет firefox.x86_64 0:45.7.0-1.el7.centos ще е обновен
---> Пакет firefox.x86_64 0:51.0.1-1.el7.sos ще е обновление
--> Обработвам зависимости: nss >= 3.28.1 за пакет: firefox-51.0.1-1.el7.sos.x86_64
--> Обработвам зависимости: nspr >= 4.13.1 за пакет: firefox-51.0.1-1.el7.sos.x86_64
--> Обработвам зависимости: libssl3.so(NSS_3.27)(64bit) за пакет: firefox-51.0.1-1.el7.sos.x86_64
--> Обработвам зависимости: libssl3.so(NSS_3.23)(64bit) за пакет: firefox-51.0.1-1.el7.sos.x86_64
--> Обработвам зависимости: libnss3.so(NSS_3.22)(64bit) за пакет: firefox-51.0.1-1.el7.sos.x86_64
--> Извършвам проверка на транзакцията
---> Пакет nspr.x86_64 0:4.11.0-1.el7_2 ще е обновен
---> Пакет nspr.x86_64 0:4.13.1-1.el7.sos ще е обновление
---> Пакет nss.x86_64 0:3.21.3-2.el7_3 ще е обновен
--> Обработвам зависимости: nss(x86-64) = 3.21.3-2.el7_3 за пакет: nss-tools-3.21.3-2.el7_3.x86_64
---> Пакет nss.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
--> Обработвам зависимости: nss-util >= 3.28.1 за пакет: nss-3.28.1-1.3.el7.sos.x86_64
--> Обработвам зависимости: nss-softokn(x86-64) >= 3.28.1 за пакет: nss-3.28.1-1.3.el7.sos.x86_64
--> Обработвам зависимости: nss-pem за пакет: nss-3.28.1-1.3.el7.sos.x86_64
--> Обработвам зависимости: libnssutil3.so(NSSUTIL_3.24)(64bit) за пакет: nss-3.28.1-1.3.el7.sos.x86_64
--> Извършвам проверка на транзакцията
---> Пакет nss-pem.x86_64 0:1.0.2-2.el7.sos ще е инсталиран
---> Пакет nss-softokn.x86_64 0:3.16.2.3-14.4.el7 ще е обновен
---> Пакет nss-softokn.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
--> Обработвам зависимости: nss-softokn-freebl(x86-64) >= 3.28.1-1.0.el7.sos за пакет: nss-softokn-3.28.1-1.0.el7.sos.x86_64
---> Пакет nss-tools.x86_64 0:3.21.3-2.el7_3 ще е обновен
---> Пакет nss-tools.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
---> Пакет nss-util.x86_64 0:3.21.3-1.1.el7_3 ще е обновен
---> Пакет nss-util.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
--> Извършвам проверка на транзакцията
---> Пакет nss-softokn-freebl.x86_64 0:3.16.2.3-14.4.el7 ще е обновен
---> Пакет nss-softokn-freebl.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for nspr which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of nspr of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude nspr.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of nspr installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of nspr installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Защитени multilib версии: nspr-4.13.1-1.el7.sos.x86_64 != nspr-4.11.0-1.el7_2.i686
Грешка: Защитени multilib версии: nss-util-3.28.1-1.0.el7.sos.x86_64 != nss-util-3.21.3-1.1.el7_3.i686
Грешка: Защитени multilib версии: nss-softokn-3.28.1-1.0.el7.sos.x86_64 != nss-softokn-3.16.2.3-14.4.el7.i686
Грешка: Защитени multilib версии: nss-3.28.1-1.3.el7.sos.x86_64 != nss-3.21.3-2.el7_3.i686
А при ъпдейт на цялата система 
Код:
# yum update
Заредени плъгини: fastestmirror, langpacks, nvidia, priorities
Loading mirror speeds from cached hostfile
* StotinkaOS-Base: stotinkaos.net
* StotinkaOS-Plus: stotinkaos.net
* StotinkaOS-Wine: stotinkaos.net
* base: mirrors.neterra.net
* elrepo: ftp.ines.lug.ro
* epel: mirror.pmf.kg.ac.rs
* extras: mirrors.neterra.net
* updates: mirrors.neterra.net
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет emacs-filesystem.noarch 1:24.3-18.el7 ще е обновен
---> Пакет emacs-filesystem.noarch 1:25.1-2.el7.sos ще е обновление
---> Пакет firefox.x86_64 0:45.7.0-1.el7.centos ще е обновен
---> Пакет firefox.x86_64 0:51.0.1-1.el7.sos ще е обновление
---> Пакет nspr.x86_64 0:4.11.0-1.el7_2 ще е обновен
---> Пакет nspr.x86_64 0:4.13.1-1.el7.sos ще е обновление
---> Пакет nss.x86_64 0:3.21.3-2.el7_3 ще е обновен
---> Пакет nss.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
--> Обработвам зависимости: nss-pem за пакет: nss-3.28.1-1.3.el7.sos.x86_64
---> Пакет nss-softokn.x86_64 0:3.16.2.3-14.4.el7 ще е обновен
---> Пакет nss-softokn.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
---> Пакет nss-softokn-freebl.x86_64 0:3.16.2.3-14.4.el7 ще е обновен
---> Пакет nss-softokn-freebl.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
---> Пакет nss-sysinit.x86_64 0:3.21.3-2.el7_3 ще е обновен
---> Пакет nss-sysinit.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
---> Пакет nss-tools.x86_64 0:3.21.3-2.el7_3 ще е обновен
---> Пакет nss-tools.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
---> Пакет nss-util.x86_64 0:3.21.3-1.1.el7_3 ще е обновен
---> Пакет nss-util.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
---> Пакет sqlite.i686 0:3.7.17-8.el7 ще е излязъл от употреба
--> Обработвам зависимости: libsqlite3.so.0 за пакет: 1:qt-4.8.5-13.el7.i686
--> Обработвам зависимости: libsqlite3.so.0 за пакет: qtwebkit-2.3.4-6.el7.i686
--> Обработвам зависимости: libsqlite3.so.0 за пакет: nss-softokn-3.16.2.3-14.4.el7.i686
---> Пакет sqlite.x86_64 0:3.7.17-8.el7 ще е излязъл от употреба
---> Пакет sqlite.x86_64 0:3.13.0-1.el7.sos ще е заместващ
---> Пакет sqlite-libs.x86_64 0:3.13.0-1.el7.sos ще е заместващ
--> Извършвам проверка на транзакцията
---> Пакет nss-pem.x86_64 0:1.0.2-2.el7.sos ще е инсталиран
---> Пакет sqlite.i686 0:3.7.17-8.el7 ще е излязъл от употреба
--> Обработвам зависимости: libsqlite3.so.0 за пакет: 1:qt-4.8.5-13.el7.i686
--> Обработвам зависимости: libsqlite3.so.0 за пакет: qtwebkit-2.3.4-6.el7.i686
--> Обработвам зависимости: libsqlite3.so.0 за пакет: nss-softokn-3.16.2.3-14.4.el7.i686
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Пакет: nss-softokn-3.16.2.3-14.4.el7.i686 (@base)
           Изисква: libsqlite3.so.0
           Премахване: sqlite-3.7.17-8.el7.i686 (@base)
               libsqlite3.so.0
           Заместен от: sqlite-3.13.0-1.el7.sos.x86_64 (StotinkaOS-Plus)
               Не е намерено
Грешка: Пакет: 1:qt-4.8.5-13.el7.i686 (@base)
           Изисква: libsqlite3.so.0
           Премахване: sqlite-3.7.17-8.el7.i686 (@base)
               libsqlite3.so.0
           Заместен от: sqlite-3.13.0-1.el7.sos.x86_64 (StotinkaOS-Plus)
               Не е намерено
Грешка: Пакет: qtwebkit-2.3.4-6.el7.i686 (@StotinkaOS-Base)
           Изисква: libsqlite3.so.0
           Премахване: sqlite-3.7.17-8.el7.i686 (@base)
               libsqlite3.so.0
           Заместен от: sqlite-3.13.0-1.el7.sos.x86_64 (StotinkaOS-Plus)
               Не е намерено
Може да пробвате с --skip-broken за да заобиколите проблема
** Намерени 4 предварително съществуващи rpmdb проблема, 'yum check' показа следното:
glibc-2.17-157.el7_3.1.i686 има липсващи изисквания на libfreebl3.so
glibc-2.17-157.el7_3.1.i686 има липсващи изисквания на libfreebl3.so(NSSRAWHASH_3.12.3)
nss-3.21.3-2.el7_3.i686 има липсващи изисквания на libfreebl3.so
nss-softokn-3.16.2.3-14.4.el7.i686 има липсващи изисквания на nss-softokn-freebl(x86-32) >= ('0', '3.16.2.3', '14.4.el7')
[Изображение: Tux-sos_new_logo.png]                                                                                                                                                                                                                                              
Отговори
#3
Изпълни:
Код:
sudo rpm -e --nodeps nspr.i686 nss-util.i686 nss-softokn.i686 nss.i686
sudo yum update


В нашето хранилище PLUS се предлагат само 64 битови версии на следните пакети по-горе, за това писка за грешка ,понеже няма по-нови версии за 32 битовите които ти имаш инсталирани . Няма как да знаем всеки потребител какви точно пакети има инсталирани и ,че ще дадат проблем, в примера на точка A1 сме дали само да се премахне пакет който знаем ,че е проблемен и идва по подразбиране в версия 7.3 . Имай на предвид ,че тези пакети щом ги имаш инсталирани значи са нужни за някое приложение което си инсталирал .
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#4
Аха значи сега ако ги изтрия някое друго приложение може да изреве с грешка.

Значи ще си играя на риск печели риск губи.

Ииии много реве тоз yum 

Код:
# yum update
Заредени плъгини: fastestmirror, langpacks, nvidia, priorities
adobe-linux-i386                                                                                                                                                       |  951 B  00:00:00    
adobe-linux-x86_64                                                                                                                                                     |  951 B  00:00:00    
base                                                                                                                                                                   | 3.6 kB  00:00:00    
elrepo                                                                                                                                                                 | 2.9 kB  00:00:00    
epel/x86_64/metalink                                                                                                                                                   |  23 kB  00:00:00    
epel                                                                                                                                                                   | 4.3 kB  00:00:00    
epel-steam                                                                                                                                                             | 2.9 kB  00:00:00    
extras                                                                                                                                                                 | 3.4 kB  00:00:00    
google-chrome                                                                                                                                                          |  951 B  00:00:00    
google-earth                                                                                                                                                           |  951 B  00:00:00    
playonlinux                                                                                                                                                            | 2.9 kB  00:00:00    
updates                                                                                                                                                                | 3.4 kB  00:00:00    
virtualbox                                                                                                                                                             |  951 B  00:00:00    
(1/2): epel/x86_64/primary_db                                                                                                                                          | 4.5 MB  00:00:01    
(2/2): epel/x86_64/updateinfo                                                                                                                                          | 725 kB  00:00:01    
Loading mirror speeds from cached hostfile
* StotinkaOS-Base: stotinkaos.net
* StotinkaOS-Plus: stotinkaos.net
* StotinkaOS-Wine: stotinkaos.net
* base: mirrors.neterra.net
* elrepo: ftp.ines.lug.ro
* epel: mirror.pmf.kg.ac.rs
* extras: mirrors.neterra.net
* updates: mirrors.neterra.net
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет emacs-filesystem.noarch 1:24.3-18.el7 ще е обновен
---> Пакет emacs-filesystem.noarch 1:25.1-2.el7.sos ще е обновление
---> Пакет firefox.x86_64 0:45.7.0-1.el7.centos ще е обновен
---> Пакет firefox.x86_64 0:51.0.1-1.el7.sos ще е обновление
---> Пакет nspr.x86_64 0:4.11.0-1.el7_2 ще е обновен
---> Пакет nspr.x86_64 0:4.13.1-1.el7.sos ще е обновление
---> Пакет nss.x86_64 0:3.21.3-2.el7_3 ще е обновен
---> Пакет nss.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
--> Обработвам зависимости: nss-pem за пакет: nss-3.28.1-1.3.el7.sos.x86_64
---> Пакет nss-softokn.x86_64 0:3.16.2.3-14.4.el7 ще е обновен
---> Пакет nss-softokn.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
---> Пакет nss-softokn-freebl.x86_64 0:3.16.2.3-14.4.el7 ще е обновен
---> Пакет nss-softokn-freebl.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
---> Пакет nss-sysinit.x86_64 0:3.21.3-2.el7_3 ще е обновен
---> Пакет nss-sysinit.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
---> Пакет nss-tools.x86_64 0:3.21.3-2.el7_3 ще е обновен
---> Пакет nss-tools.x86_64 0:3.28.1-1.3.el7.sos ще е обновление
---> Пакет nss-util.x86_64 0:3.21.3-1.1.el7_3 ще е обновен
---> Пакет nss-util.x86_64 0:3.28.1-1.0.el7.sos ще е обновление
---> Пакет sqlite.i686 0:3.7.17-8.el7 ще е излязъл от употреба
--> Обработвам зависимости: libsqlite3.so.0 за пакет: 1:qt-4.8.5-13.el7.i686
--> Обработвам зависимости: libsqlite3.so.0 за пакет: qtwebkit-2.3.4-6.el7.i686
---> Пакет sqlite.x86_64 0:3.7.17-8.el7 ще е излязъл от употреба
---> Пакет sqlite.x86_64 0:3.13.0-1.el7.sos ще е заместващ
---> Пакет sqlite-libs.x86_64 0:3.13.0-1.el7.sos ще е заместващ
--> Извършвам проверка на транзакцията
---> Пакет nss-pem.x86_64 0:1.0.2-2.el7.sos ще е инсталиран
---> Пакет sqlite.i686 0:3.7.17-8.el7 ще е излязъл от употреба
--> Обработвам зависимости: libsqlite3.so.0 за пакет: 1:qt-4.8.5-13.el7.i686
--> Обработвам зависимости: libsqlite3.so.0 за пакет: qtwebkit-2.3.4-6.el7.i686
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Пакет: 1:qt-4.8.5-13.el7.i686 (@base)
           Изисква: libsqlite3.so.0
           Премахване: sqlite-3.7.17-8.el7.i686 (@base)
               libsqlite3.so.0
           Заместен от: sqlite-3.13.0-1.el7.sos.x86_64 (StotinkaOS-Plus)
               Не е намерено
Грешка: Пакет: qtwebkit-2.3.4-6.el7.i686 (@StotinkaOS-Base)
           Изисква: libsqlite3.so.0
           Премахване: sqlite-3.7.17-8.el7.i686 (@base)
               libsqlite3.so.0
           Заместен от: sqlite-3.13.0-1.el7.sos.x86_64 (StotinkaOS-Plus)
               Не е намерено
Може да пробвате с --skip-broken за да заобиколите проблема
** Намерени 49 предварително съществуващи rpmdb проблема, 'yum check' показа следното:
glibc-2.17-157.el7_3.1.i686 има липсващи изисквания на libfreebl3.so
glibc-2.17-157.el7_3.1.i686 има липсващи изисквания на libfreebl3.so(NSSRAWHASH_3.12.3)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnspr4.so
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.10)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.12)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.12.1)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.12.5)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.2)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.3)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.4)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.5)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.9.2)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnss3.so(NSS_3.9.3)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libnssutil3.so
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libplc4.so
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libplds4.so
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libsmime3.so
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libssl3.so
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libssl3.so(NSS_3.11.4)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libssl3.so(NSS_3.14)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libssl3.so(NSS_3.2)
libcurl-7.29.0-35.el7.centos.i686 има липсващи изисквания на libssl3.so(NSS_3.4)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnspr4.so
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.10)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.11)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.11.1)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.12)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.12.1)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.12.5)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.12.9)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.2)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.3)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.4)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.6)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.8)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.9.2)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnss3.so(NSS_3.9.3)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libnssutil3.so
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libplc4.so
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libplds4.so
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libsmime3.so
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libssl3.so
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libssl3.so(NSS_3.14)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libssl3.so(NSS_3.2)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libssl3.so(NSS_3.4)
openldap-2.4.40-13.el7.i686 има липсващи изисквания на libssl3.so(NSS_3.7.4)
steam-1.0.0.54-2.el7.i686 има липсващи изисквания на nss(x86-32)

Обнових само Firefox изключих хранилището StotinkaOS-Plus и вече няма проблем със Yum update.

Благодаря за помоща firefox си се обнови със 64битовите зависимости до версия 51.
[Изображение: Tux-sos_new_logo.png]                                                                                                                                                                                                                                              
Отговори
#5
Реве защото имаш един куп инсталирани 32 битови пакети , които изискват съответно и подобни библиотеки . Както казах, това хранилище обновява някои пакети но не предлага 32 битови версии , явно може да ползваш skype, steam и други подобни , за това да си се обвързал толкоз много . При такъв случай това хранилище няма да ти е от ползва поне при тебе, може да пробваш ,ако толкоз държиш на най-новият Firefox е да го инсталираш от source .
Друго важно което трябва да се знае , това ,че предлагаме най-новият Firefox не значи ,че старият е не годен и ,че трябва всеки да се хвърля на най-новият задължително . Това е само още една алтернатива която се опитваме да въведем, може на по преден етап да сложим и 32 битовите версии но за сега се задържаме от такова нещо .
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#6
Според мен на този етап не е добра идея да се надгражда Firefox.Хрома и Орера инсталирана по този начин https://www.stotinkaos.net/forums/thread...age-2.html работят много по добре от Лисицата.Само трябва да се свикне.
Отговори
#7
(30-01-2017, 09:19)океан написа: Според мен на този етап не е добра идея да се надгражда Firefox.Хрома и Орера инсталирана по този начин ... работят много по добре от Лисицата.Само трябва да се свикне.

Въпреки, че вече го написах в началния пост, нека го кажа с други думи. Стандартната версия Firefox ESR, която идва по подразбиране в StotinkaOS се поддържа много добре и по нищо толкова съществено не отстъпва на Хром и Опера. Към момента е налична 45.7.0 и в този ъпдейт бяха изчистени доста неща, включително и h.264 поддръжката на видео в YouTube. Т.е. по нашите тестове ESR 45.7.0 сравнен с версията, с която върви Мозила стандартно към момента 51.0.1 почти по нищо не се различава като скорост и поддръжка на основните неща.

Това, че пуснахме такава възможност да се инсталира по-новата версия съвсем не означава, че то е заради някакви проблеми на ESR стандартната ни версия. Просто от екипа решихме, че би било хубаво да осигурим такава поддръжка на най-новата версия, за да може хора, които наистина имат нужда от по-новата версия по една или друга причина, да могат да имат лесен достъп през хранилищата ни. Само като пример такива хора може да са разработчици на различни приложения и добавки за Firefox или такива, които искат да провеждат тестове и QA на по-новите версии, за да докладват и подпомагат развитието на браузъра. Както сами знаете, нашия екип освен, че се стреми да прави една по-лесна за употреба от потребителите дистрибуция, паралелно с това ние се стремим да запазим и осигурим повече функционалности за експертите и това дори ни е заложено в портфолиото.

Предвид всичко до тук, не сме казали, че всички потребители, е задължително или дори препоръчително да минават на най-новата версия на Firefox и мисля, че това става ясно още в началния пост на темата. Също така новата версия не случайно се намира в StotinkaOS-Plus хранилището. То е изключено по подразбиране, с него се работи изключително внимателно и е задължително да се активира само тогава, когато потребителя е наясно със ситуацията и пакетите, зависимостите в система си и кои пакети могат да се надграждат между хранилищата, за да се избегне тези грешки и да се запази стабилността на дистрибуцията. Разбира се точно за това сме дали и линк към самото хранилище, за да може да се види какво има в него преди да бъде активирано.

И все пак ако до сега не е била достатъчно ясно целта за пускането на този пакет на Firefox, искрено се извиняваме за неразбирателството! Ако искате за потребители, които просто желаят да разгледат, поработят и да тестват последните версии на браузъра, без да се налага да активират PLUS хранилището и не са сигурни в това какво правят, може просто за ваше улеснение да напишем един елементарен инстал на бинарните версии предлагани от Mozilla, с които да пробвате Firefox в новите му версии, но не можем да се ангажираме с дългосрочна поддръжка по-този начин, защото това не е професионално и излиза от рамките на проекта ни.
Отговори
#8
Всички 32-битови зависимости са вече качени в хранилището Plus, така ,че би трябвало това да реши проблема при актуализации от сега на татък . Ако отново има проблем ще се радваме да ни бъде докладвано за да го отстраним в минимален срок от време.

edit: Там където Стъпка A1 и точка 2 от първият пост на ръководството , може да не бъде изпълнявано .

Приятно ползване на Firefox ML в StotinkaOS 7 !
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори
#9
(31-01-2017, 16:52)ivo написа: Всички 32-битови зависимости са вече качени в хранилището Plus, така ,че би трябвало това да реши проблема при актуализации от сега на татък .  Ако отново има проблем ще се радваме да ни бъде докладвано за да го отстраним в минимален срок от време.

edit: Там където Стъпка A1 и точка 2 от първият пост на ръководството , може да не бъде изпълнявано .

Приятно ползване на Firefox ML в StotinkaOS 7 !

Редактирах началния пост и премахнах А1 т.2, за да няма объркване.
Отговори
#10
Преди няколко дена пуснаха Firefox 52 ESR от CentOS хранилището а ние все още имаме Firefox 51 ML в нашето на PLus , може да се каже че ни из предвариха с един/два дена преди да обновим пакета до v52 и зависимостите. Тези които ползвате FF от нашето хранилище ще получили ъпдейти за него с версия 52 ESR също ъпдейти на пакетите nss* които са нужни зависимости за новият FF . Твърде възможно според зависи които пакети точно имате инсталирани от тях е да се получат и конфликти . Тези пакети съдържат някои сертификати и лошото е ,че ако потребителя изтрие някой пакет от тях лесно може да счупи yum и системата понеже той също ги ползва . Трябва да се действа много внимателно , за това днеска пакета Firefox от StotinkaOS Plus ще бъде премахнат заедно със всички nss* и sqlite пакети които бяха нужни като зависимости .
Този път малко не ни излязоха добре сметките, явно поддръжката на двете версии има твърде висока цена , така ,че по добре е да си признаем грешките и да се опитаме да ги оправим Smile.
* StotinkaOS SOS хранилища .
* (NEW) Fedora COPR хранилища .

Не отговарям на технически въпроси на ЛС.
Отговори




Потребители разглеждащи темата: 1 гост(и)