Проблем при актуализация
#1
При актуализация на Стотинка 6.8 ми даде тази грешка.Какво може да се направи?



16:21:07 : network interface eth0 (e100) is connected
16:21:07 : Свързан към мрежа
16:21:07 : network interface eth0 (e100) is connected
16:21:07 : Стартиране на дъщерен yum процес
16:21:14 : YUM: Yum Version : 3.2.29
16:21:14 : YUM: Loaded plugins: fastestmirror, presto, priorities
16:21:14 : Взимам наличните обновления
16:21:14 : YUM: Loading mirror speeds from cached hostfile
16:21:15 : YUM:  * base: centos.uni-sofia.bg
16:21:15 : YUM:  * elrepo: mirrors.xservers.ro
16:21:15 : YUM:  * epel: mirrors.coreix.net
16:21:15 : YUM:  * rpmfusion-free-updates: mirror.telepoint.bg
16:21:15 : YUM:  * rpmfusion-nonfree-updates: mirror.telepoint.bg
16:21:15 : YUM:  * updates: centos.uni-sofia.bg
16:21:16 : 1 върнати пакети
16:21:17 : Взимам наличните излезли от употреба
16:21:17 : 0 върнати пакети
16:21:17 : Adding Packages to view
16:21:17 : Added 1 Packages to view
16:21:43 : YUM: --> Running transaction check
16:21:43 : YUM: ---> Package libdvbpsi.i686 0:0.2.2-2.el6 will be updated
16:21:43 : YUM: --> Processing Dependency: libdvbpsi.so.7 for package: vlc-core-2.0.10-1.el6.i686
16:21:43 : YUM: ---> Package libdvbpsi.i686 0:1.2.0-3.el6 will be an update
16:21:44 : YUM: --> Finished Dependency Resolution
16:21:44 : YUM: --> Finding unneeded leftover dependencies
16:21:44 : YUM: Found and removing 0 unneeded dependencies
16:22:10 : ERROR: Удовлетворяването на зависимости завърши с грешки
16:22:10 : ERROR:   Package: vlc-core-2.0.10-1.el6.i686 (@rpmfusion-free-updates/$releasever)
   Requires: libdvbpsi.so.7
   Removing: libdvbpsi-0.2.2-2.el6.i686 (@rpmfusion-free-updates/$releasever)
       libdvbpsi.so.7
   Updated By: libdvbpsi-1.2.0-3.el6.i686 (epel)
       Not found
Отговори
#2
Тя тая актоализация  май е за Стотинка ос 7,3  при теб може да я пропуснеш.

Пробема май се решаваше ето така:

Пишеш в терминал 

Код:
yum -x libdvbpsi
Отговори
#3
Да както колегата Стилиян е предложил може да добавиш пакета да не се актуализира . Аз обаче бих ти предложил да го добавиш директно във /etc/yum.conf ,ето така :

Най-долу във файла постави

exclude=libdvbpsi

После ще може да актуализираш спокойно . Проблема се състои в това ,че са пуснали нова версия на въпросния пакет , който чупи VLC .
Ще трябва да се намери решение, най вероятно билдване на VLC със по нови библиотеки, това обаче под версия 6 ще стане трудно , понеже VLC се предлага от RrpmFusion хранилището което май от доста време не си подновява пакетите . Ще трябва скоро да се заемем и със версия шест на Стотинка, като по освежим малко пакетите и ги билднем за нас .
Не отговарям на технически въпроси на ЛС.
Отговори
#4
Благодаря .
Отговори
#5
Няма защо, нека седи темата отворена тъй като това е само временно решение на проблема .
Не отговарям на технически въпроси на ЛС.
Отговори




Потребители разглеждащи темата: 1 гост(и)