Проблем последна актуализация
#1
Здравейте, реших да видя има ли някоя нова актуализация и се натъкнах на проблем

Код:
[matrata@localhost ~]$ sudo yum update
Заредени плъгини: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
* base: mirror.bg.host.ag
* elrepo: mirrors.netix.net
* epel: mirrors.neterra.net
* extras: mirror.bg.host.ag
* updates: mirror.bg.host.ag
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет libfm.x86_64 0:1.2.3-1.el7.sos ще е обновен
---> Пакет libfm.x86_64 0:1.2.4-3.el7 ще е обновление
---> Пакет libfm-gtk.x86_64 0:1.2.3-1.el7.sos ще е обновен
--> Обработвам зависимости: libfm-gtk.so.4()(64bit) за пакет: pcmanfm-1.2.3-1.el7.sos.x86_64
--> Обработвам зависимости: libfm-gtk.so.4()(64bit) за пакет: lxpanel-0.8.2-1.el7.sos.x86_64
---> Пакет libfm-gtk.x86_64 0:1.2.4-3.el7 ще е обновление
---> Пакет libfm-gtk-utils.x86_64 0:1.2.3-1.el7.sos ще е обновен
---> Пакет libfm-gtk-utils.x86_64 0:1.2.4-3.el7 ще е обновление
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies
Грешка: Пакет: lxpanel-0.8.2-1.el7.sos.x86_64 (@StotinkaOS-Base)
            Изисква: libfm-gtk.so.4()(64bit)
            Премахване: libfm-gtk-1.2.3-1.el7.sos.x86_64 (@StotinkaOS-Base)
                libfm-gtk.so.4()(64bit)
            Обновен от: libfm-gtk-1.2.4-3.el7.x86_64 (epel)
               ~libfm-gtk3.so.4()(64bit)
Грешка: Пакет: pcmanfm-1.2.3-1.el7.sos.x86_64 (@StotinkaOS-Base)
            Изисква: libfm-gtk.so.4()(64bit)
            Премахване: libfm-gtk-1.2.3-1.el7.sos.x86_64 (@StotinkaOS-Base)
                libfm-gtk.so.4()(64bit)
            Обновен от: libfm-gtk-1.2.4-3.el7.x86_64 (epel)
               ~libfm-gtk3.so.4()(64bit)
Може да пробвате с --skip-broken за да заобиколите проблема
Може да пробвате като стартирате: rpm -Va --nofiles --nodigest
[matrata@localhost ~]$
Отговори
#2
Ок мерси ,че докладва за това Цецко.
Явно от EPEL са пуснали пакета за libfm поради това,че вече е налична работната среда LXQT , който се различава от нашият и това е проблем .
Ако не използваш LXDE може да премахнеш зависимостите pcmanfm и lxpanel , също останалите пакети свързани с LXDE , yum remove @lxde-desktop би трябвало да реши проблема с актуализация .

Ако пък използваш LXDE , то направи следното .

Добави във /etc/yum.repos.d/epel.repo , там където [epel] линията exclude=libfm*
Не отговарям на технически въпроси на ЛС.
Отговори
#3
При последната актуализация дава грешка.
Код:
Обновяване:
stotinkaos-defaults     noarch     0.3-2.el7.sos     StotinkaOS-Base      29 k

Обобщение на транзакцията
================================================================================
Надгради  1 Пакет

Общ обем: 29 k
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/glib-2.0/schemas/org.stotinkaos.gschema.override from install of stotinkaos-defaults-0.3-2.el7.sos.noarch conflicts with file from package stotinkaos-xfce-defaults-0.2-1.el7.sos.noarch

Обобщение на грешките
---------------------

[root@localhost Плот]#
Отговори
#4
Много странно как така имаш инсталирани и двата пакета, в момента не виждам как може да е станало понеже двата пакета са конфликтни . Трябва да опитаме да ги премахнем без да изтрием нещо нужно .

Коя работна среда и кой образ си си свалил?
Не отговарям на технически въпроси на ЛС.
Отговори
#5
Здравейте, и аз имам проблем с последната актуализация при мен грешката е следната:

sudo yum update
Заредени плъгини: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* StotinkaOS-Base: mirrors.uni-ruse.bg
* StotinkaOS-Wine: mirrors.uni-ruse.bg
* base: mirrors.uni-ruse.bg
* elrepo: mirrors.netix.net
* epel: mirrors.uni-ruse.bg
* extras: mirrors.uni-ruse.bg
* linuxtech-release: pkgrepo.linuxtech.net
* updates: mirrors.uni-ruse.bg
Определяне на зависимостите
--> Извършвам проверка на транзакцията
---> Пакет flash-plugin.x86_64 0:24.0.0.194-release ще е обновен
---> Пакет flash-plugin.x86_64 0:24.0.0.221-release ще е обновление
--> Завърших определянето на зависимости
--> Търся ненужни останали зависимости
Found and removing 0 unneeded dependencies

Зависимостите са удовлетворени

================================================================================
Package Архитектура
Версия Хранилище Обем
================================================================================
Обновяване:
flash-plugin x86_64 24.0.0.221-release adobe-linux-x86_64 9.2 M

Обобщение на транзакцията
================================================================================
Надгради 1 Пакет

Общ обем: 9.2 M
Is this ok [y/d/N]: y
Downloading packages:
warning: /var/cache/yum/x86_64/7/adobe-linux-x86_64/packages/flash-player-npapi-24.0.0.221-release.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY
Извличане на ключ от file:///etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux


Извличането на GPG ключ не успя: [Errno 14] curl#37 - "Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux"
Отговори
#6
Здрасти , изпълни всичко което се пише тук https://www.stotinkaos.net/forums/thread...ml#pid8374 с sudo/root и след това обнови отново .
Проблема ще бъде оправен в по-новата версия на sos-easy . Идва от това, че в версия 7.3 на Стотинка разкарахме флаш хранилището и флаш пакета по подразбиране за сметка на това го предлагаме чрез инсталиране от sos-easy , но в инсталацията от sos-easy е забравен GPG ключа , това ще бъде фиксната в другата версия на приложението .

Ти след като изпълниш горните команди от поста вече ще го имаш добавен .
Не отговарям на технически въпроси на ЛС.
Отговори
#7
(18-02-2017, 01:34)ivo написа: Здрасти , изпълни всичко което се пише тук https://www.stotinkaos.net/forums/thread...ml#pid8374 с sudo/root и след това обнови  отново .
Проблема ще бъде оправен в по-новата версия на sos-easy . Идва от това, че в версия 7.3 на Стотинка разкарахме флаш хранилището и флаш пакета по подразбиране за сметка на това го предлагаме чрез инсталиране от sos-easy , но в инсталацията от sos-easy е забравен GPG ключа , това ще бъде фиксната в другата версия на приложението .

Ти след като изпълниш горните команди от поста вече ще го имаш добавен .

получи се много благодаря за бързия отговор и за помощта. Въпросната тема наистина съм я пропуснал... за пореден път.
Отново благодаря и лека вечер

П.С. само забравих да попитам бъдещи актуализации на пакета само от sos-easy ли ще са възможни, или ще се запази възможността за ъпдейт чрез yum?
Отговори
#8
(17-02-2017, 22:35)ivo написа: Много странно как така имаш инсталирани и двата пакета, в момента не виждам как може да е станало понеже двата пакета са конфликтни . Трябва да опитаме да ги премахнем без да изтрием нещо нужно .

Коя работна среда и кой образ си си свалил?

Инсталирано е от образа с XFCE среда. От SOS е инсталирано и Mate и Cinnamon.Инсталирано е на
26.10.2016 г.До сега всички ъпдейти са инсталирани.
Отговори
#9
(18-02-2017, 08:43)океан написа: Инсталирано е от образа с XFCE среда. От SOS е инсталирано и Mate и Cinnamon.Инсталирано е на
26.10.2016 г.До сега всички ъпдейти са инсталирани.

Добре, трябва да премахнеш един от двата пакета, не знам кой ще е по добре да оставиш след като ползваш толкова работни среди едновременно . Но който и да премахнеш не би трябвало да имаш никакви проблеми. Предлагам да махнеш този с по малко зависимости stotinkaos-xfce-defaults .

Обаче деинсталирай така:

Код:
sudo rpm -e --nodeps stotinkaos-xfce-defaults

След което пробвай да ъпдейтнеш наново . Ще видим да форсираме двата пакета да не могат да се инсталират заедно .

(18-02-2017, 01:41)Tiger написа: П.С. само забравих да попитам бъдещи актуализации на пакета само от sos-easy ли ще са възможни, или ще се запази възможността за ъпдейт чрез yum?

Ъпдейтите си ги прави както и до сега, използвайки yum или yumex от sos-easy не се правят ъпдейти от него само се инсталират приложения.
Не отговарям на технически въпроси на ЛС.
Отговори
#10
Благодаря.Всичко стана без грешки.
Отговори




Потребители разглеждащи темата: 1 гост(и)